Why does usage in content_repo exceed usage shown in UI?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Why does usage in content_repo exceed usage shown in UI?

James McMahon
I seem to be having a problem with my content repo. It appears that several workflows running concurrently are filling it to capacity, and then all flow grinds to a halt.

I noticed that after stopping some development workflows, my usage dropped from 100% of the content repo to only 54%. Roughly 24 GB were liberated. But in my NiFi UI in the header section, it reports less than 1GB in use. Why does my df -hk at the file system level still show me using 54% of the content repo capacity - roughly 26GB? That discrepancy between the two utilization figures seems very large.

Jim
Reply | Threaded
Open this post in threaded view
|

Re: Why does usage in content_repo exceed usage shown in UI?

Pierre Villard
Hi James,

I'd recommend the reading of the following article [1]. It gives a pretty good idea of what is going on and how to tune it to get the behavior you expect.

[1] https://community.hortonworks.com/articles/82308/understanding-how-nifis-content-repository-archivi.html

Hope this helps,
Pierre

2017-06-16 18:05 GMT+02:00 James McMahon <[hidden email]>:
I seem to be having a problem with my content repo. It appears that several workflows running concurrently are filling it to capacity, and then all flow grinds to a halt.

I noticed that after stopping some development workflows, my usage dropped from 100% of the content repo to only 54%. Roughly 24 GB were liberated. But in my NiFi UI in the header section, it reports less than 1GB in use. Why does my df -hk at the file system level still show me using 54% of the content repo capacity - roughly 26GB? That discrepancy between the two utilization figures seems very large.

Jim

Reply | Threaded
Open this post in threaded view
|

Re: Why does usage in content_repo exceed usage shown in UI?

James McMahon
Thank you very much Pierre. This looks like just what I need to better understand to manage our situation. Have a good weekend. -Jim

On Fri, Jun 16, 2017 at 12:40 PM, Pierre Villard <[hidden email]> wrote:
Hi James,

I'd recommend the reading of the following article [1]. It gives a pretty good idea of what is going on and how to tune it to get the behavior you expect.

[1] https://community.hortonworks.com/articles/82308/understanding-how-nifis-content-repository-archivi.html

Hope this helps,
Pierre

2017-06-16 18:05 GMT+02:00 James McMahon <[hidden email]>:
I seem to be having a problem with my content repo. It appears that several workflows running concurrently are filling it to capacity, and then all flow grinds to a halt.

I noticed that after stopping some development workflows, my usage dropped from 100% of the content repo to only 54%. Roughly 24 GB were liberated. But in my NiFi UI in the header section, it reports less than 1GB in use. Why does my df -hk at the file system level still show me using 54% of the content repo capacity - roughly 26GB? That discrepancy between the two utilization figures seems very large.

Jim