SSLContextService Issue on Minifi

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

SSLContextService Issue on Minifi

Harrison Unruh
Hello,

I've been trying to configure Minifi to work with the SSLContextService,
and have been running into an error I can't find much documentation on:

ERROR [main] o.apache.nifi.controller.FlowController Unable to start
PostHTTP[id=80508d8d-015d-1000-0000-000000000000] due to
java.lang.IllegalStateException: Processor PostHTTP is not in a valid state
due to ['SSL Context Service' validated against
'854b66f7-015d-1000-0000-000000000000' is invalid because
StandardSSLContextService - 0.2.0 from org.apache.nifi.minifi -
minifi-ssl-context-service-nar is not compatible with SSLContextService -
unversioned from default - system]

I've tried quite a few configurations of the StandardSSLContextService I'm
using in my flow but haven't been able to avoid this. I was wondering if
you would have any ideas on what would cause this?

Thanks!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SSLContextService Issue on Minifi

Aldrin Piri
Hi Harrison,

Sorry to have overlooked this.  Would you be able to share the config you
are using for your attempt?

On Thu, Jul 27, 2017 at 3:24 PM, Harrison Unruh <[hidden email]>
wrote:

> Hello,
>
> I've been trying to configure Minifi to work with the SSLContextService,
> and have been running into an error I can't find much documentation on:
>
> ERROR [main] o.apache.nifi.controller.FlowController Unable to start
> PostHTTP[id=80508d8d-015d-1000-0000-000000000000] due to
> java.lang.IllegalStateException: Processor PostHTTP is not in a valid
> state
> due to ['SSL Context Service' validated against
> '854b66f7-015d-1000-0000-000000000000' is invalid because
> StandardSSLContextService - 0.2.0 from org.apache.nifi.minifi -
> minifi-ssl-context-service-nar is not compatible with SSLContextService -
> unversioned from default - system]
>
> I've tried quite a few configurations of the StandardSSLContextService I'm
> using in my flow but haven't been able to avoid this. I was wondering if
> you would have any ideas on what would cause this?
>
> Thanks!
>
Loading...