PutElasticSearch5 errors

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

PutElasticSearch5 errors

zmichael1
Hi, I'm trying to use Apache Nifi 1.3.0 to fetch data from a postgres
database (and from file System also) and put them into ElasticSearch 5.2.2
(I've also try with elasticSearch 5.0.0 and 5.0.1 but the result is the
same). So this is my Nifi dataflow for database:

<http://apache-nifi-developer-list.39713.n7.nabble.com/file/n16199/nifi_dataflow.png>

And this is the QueryDatabaseTable config:

<http://apache-nifi-developer-list.39713.n7.nabble.com/file/n16199/nifi_config_1.png>

And the PutElasticSearch5 config is

<http://apache-nifi-developer-list.39713.n7.nabble.com/file/n16199/nifi_config_2.png>

And the DBCPConnectionPool config

<http://apache-nifi-developer-list.39713.n7.nabble.com/file/n16199/nifi_config_3.png>

So when i run each of the processor, everything work as expected on the
QueryDatabaseTable (The same on the GetFile processsor) but on my
elasticsearch instance i got this exception:
*org.elasticsearch.index.mapper.MapperParsingException: failed to parse*
*Caused by: org.elasticsearch.common.compress.NotXContentException:
Compressor detection can only be called on some xcontent bytes or compressed
xcontent bytes
        at
org.elasticsearch.common.compress.CompressorFactory.compressor(CompressorFactory.java:57)
~[elasticsearch-5.2.2.jar:5.2.2]
        at
org.elasticsearch.common.xcontent.XContentHelper.createParser(XContentHelper.java:48)
~[elasticsearch-5.2.2.jar:5.2.2]
        at
org.elasticsearch.index.mapper.DocumentParser.parseDocument(DocumentParser.java:62)
~[elasticsearch-5.2.2.jar:5.2.2]* as shown on this sreenshot

<http://apache-nifi-developer-list.39713.n7.nabble.com/file/n16199/exception.png>


The same exception with ElasticSearch 5.0.0 and 5.0.1. Even when i try the
PutElasticSearch processor with ElasticSearch 2.4.0.

So am i missing something in my config? Or did i need to convert the
FlowFiles in a particular format (JSON for exemple) to get it worked with
ElasticSearch?
Please help me. :-)




--
View this message in context: http://apache-nifi-developer-list.39713.n7.nabble.com/PutElasticSearch5-errors-tp16199.html
Sent from the Apache NiFi Developer List mailing list archive at Nabble.com.